Knowledgebase
Yourika Corp. > Yourika Help Desk > Knowledgebase

Search help:


Why can't tymoraPRO find my version of JAVA?

Solution

tymoraPRO currently uses the 32-bit version of Java (ideally, the latest Java version 8) for some components such Dukascopy JForex or FXCM ForexConnect.  While tymoraPRO can usually identify the correct version to use on its own, sometimes there may be difficulties depending on how your system is configured.

For more information on what may be wrong, from a command prompt, you can try typing:

\tymdata\dchndlr test

This will show where tymoraPRO is looking for your 32-bit JAVA installation.

For example, if it shows:

JAVA_HOME="C:\Program Files (x86)\Java\jre1.8.0_60\bin\java.exe"

but your Java version is " jre-8u73-windows-i586.exe ", then you will have to modify your JAVA_HOME to reflect:

JAVA_HOME="C:\Program Files (x86)\Java\jre1.8.0_73\bin\java.exe"

JAVA_HOME can be set in Windows from System Properties -> Advanced -> Environment Variables.

If JAVA_HOME exists in both "User variables" and "System variables", make sure to correct both entries.

If you still have problems, you can also force the tymoraPRO handler to look in a particular place.  For example, with the Dukascopy handler, you can add the following line to " \tymdata\dchndlr.cfg9442 " using notepad or some other text editor:

JAVA_HOME=C:\Program Files (x86)\Java\jre1.8.0_73\bin\java.exe

Remember that if you upgrade JAVA again in the future, your JAVA_HOME variable may also need to be updated again as well.

 

 
Was this article helpful? yes / no
Article details
Article ID: 33
Category: tymoraPRO tradeSCAN
Date added: 2022-07-24 16:57:18
Views: 1267
Rating (Votes): Article rated 3.8/5.0 (44)

 
« Go back

 
Powered by Help Desk Software HESK - brought to you by Help Desk Software SysAid